frontendmemo

このサイトは、「html、css、js、ruby,ツールなどについて、自分が覚えたこと、またはいつも忘れて調べることを書き溜め、それが結果といて勉強したての初心者の方や自分と同じような技術レベルの人の助けになることを目的とするWebログ」、略してブログです。挨拶→http://frontendmemo.hatenablog.com/entry/2016/06/25/115845

LoadError (cannot load such file -- aws-sdk-s3 (You may need to install the aws-sdk-s3 gem)):のエラー解決

スポンサードリンク


スポンサードリンク


タイトルのようにLoadError (cannot load such file -- aws-sdk-s3 (You may need to install the aws-sdk-s3 gem))というエラーが出たのですが、
gem 'aws-sdk', '~> 2.3'
を既にインストールしていたためgem 'aws-sdk-s3'を入れようとすると、

Bundler could not find compatible versions for gem "aws-sdk-core":
In snapshot (Gemfile.lock):
aws-sdk-core (= 2.11.154)

In Gemfile:
aws-sdk (~> 2.3) was resolved to 2.11.154, which depends on
aws-sdk-resources (= 2.11.154) was resolved to 2.11.154, which depends on
aws-sdk-core (= 2.11.154)

aws-sdk-s3 was resolved to 1.0.0.rc5, which depends on
aws-sdk-core (= 3.0.0.rc1)

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.

というエラーが出ました。

bundle updateをしたのですが
Resolving dependencies..............がずっと続いて終わらない状態に。。

gem 'aws-sdk', '~> 3'としたところ解決しました。