frontendmemo

このサイトは、「html、css、js、ruby,ツールなどについて、自分が覚えたこと、またはいつも忘れて調べることを書き溜め、それが結果といて勉強したての初心者の方や自分と同じような技術レベルの人の助けになることを目的とするWebログ」、略してブログです。挨拶→http://frontendmemo.hatenablog.com/entry/2016/06/25/115845

prettierで大量のエラーが発生→コマンド一発で解消

スポンサードリンク


スポンサードリンク


コードを自動で成形してくれるprettier便利なのですが、無駄にエラーが発生してストレス感じますね。

大量のエラーが発生することもあるのですが、まるで「バルス」のようにコマンド一発で消すことができたので紹介します。

経緯

VSCODEでprettier拡張機能をinstall、html側で下記のようなエラーが大量発生

Module Warning (from ./node_modules/@vue/cli-plugin-eslint/node_modules/eslint-loader/index.js):
warning: Insert `··` (prettier/prettier) at 

スペースとかタブとか改行などいろいろ試すも変わらず。。

対処法

下記コマンドで解消します。

yarn run lint --fix

そもそもprettier自体、自動でコードを成型してくれるはずなのにエラーなんて出さないで勝手に修正してほしいのですね。
同じような現象が起きた方の救いになれば幸いです。